To view uptime history for your instance of Canvas, click here.

A very small subset of users experiencing slowness and timeouts in Canvas
Incident Report for Instructure
Resolved
Performance has been restored and appears to be stable. The small percentage of affected users should no longer be affected by the slowness and timeout errors they've been seeing this morning (displayed as blank, white pages). We apologize for any trouble this has caused, and appreciate your patience as this was addressed.
Posted May 26, 2016 - 12:55 MDT
Monitoring
Our Operations team has identified the cause for the slowness and timeouts some users have been seeing in Canvas. They've implemented a solution to restore normal performance, and things are looking good again within the site. They will continue to monitor performance to ensure users can access Canvas without any trouble. We'll provide another update in 15 minutes.
Posted May 26, 2016 - 12:33 MDT
Update
Some users are still experiencing slowness and intermittent timeouts in Canvas. Our Operations team is actively working to identify the cause so a fix can be implemented. We'll send a new update in 15 minutes.
Posted May 26, 2016 - 12:08 MDT
Investigating
A small number of users are experiencing slowness and timeouts in Canvas once again today. Our Operations team is actively looking into the issue and we'll provide an update in another 15 minutes or less.
Posted May 26, 2016 - 11:52 MDT