To view uptime history for your instance of Canvas, click here.

Roll Call Attendance Loading Slowly
Incident Report for Instructure
Resolved
Our Operations team has deployed a fix to allow the Roll Call Attendance tool to load normally once again. Please contact Canvas Support if you see any further issues with this application. Thank you!
Posted Apr 28, 2015 - 13:12 MDT
Investigating
The Roll Call Attendance tool is again exhibiting slow load times. The tool will load, though it may take up to a few minutes. We apologize for any inconvenience this is causing for you in your courses. Our Operations team is investigating the issue to find any new causes resulting in this behavior to keep it from happening again. We will provide an update as soon as we can.
Posted Apr 28, 2015 - 12:53 MDT