To view uptime history for your instance of Canvas, click here.

Some users receiving a white page with a 503 error
Incident Report for Instructure
Resolved
This incident has been resolved.
Posted Jun 20, 2017 - 19:40 MDT
Monitoring
Our DevOps team has been looking into the issue. The issue appears to be resolved, we will continue to monitor the issue.
Posted Jun 20, 2017 - 19:39 MDT
Investigating
Some users have reported receiving a white page with a 503 error. Our DevOps team is looking into the issue. We expect the issue to resolved momentarily.
Posted Jun 20, 2017 - 19:29 MDT