To view uptime history for your instance of Canvas, click here.

Users experiencing slowness and timeouts in Canvas
Incident Report for Instructure
Resolved
Between 10:42 AM and 10:57 AM MDT, a small percentage of Canvas users experienced slowness and timeouts. This issue has since been resolved by our DevOps team. We appreciate your patience, and apologize for any inconvenience this may have caused.
Posted May 27, 2017 - 11:05 MDT
Monitoring
Starting at 10:42 AM MDT a small percentage of Canvas users have been experiencing slowness and timeouts. Our DevOps team is currently investigating this issue. We will provide an update once we have resolved the outage. We appreciate your patience, and apologize for any inconvenience this may have caused.
Posted May 27, 2017 - 10:55 MDT